help - macports modules not found?

Johnson, Matthew Matthew.Johnson at
Fri Jun 11 08:53:01 PDT 2010

Hi all-
I have searched everywhere, but I am new to perl and can't seem to find the answer. I installed macports 1.8.2 on 10.6.3 (xcode 3.2.2 installed), installed some modules using "sudo port install ..." but when I run a perl program I get, e.g.,

Can't locate in @INC (@INC contains: /opt/local/lib/perl5/site_perl/5.8.9/darwin-2level /opt/local/lib/perl5/site_perl/5.8.9 /opt/local/lib/perl5/site_perl /opt/local/lib/perl5/vendor_perl/5.8.9/darwin-2level /opt/local/lib/perl5/vendor_perl/5.8.9 /opt/local/lib/perl5/vendor_perl /opt/local/lib/perl5/5.8.9/darwin-2level /opt/local/lib/perl5/5.8.9 .) at ./ line 21.
BEGIN failed--compilation aborted at ./ line 21.

The module is installed:
$ port installed
The following ports are currently installed:
 atk @1.30.0_0 (active)
 autoconf @2.65_1 (active)
 automake @1.11.1_0 (active)
 bzip2 @1.0.5_3+darwin (active)
 cairo @1.8.10_0+macosx (active)

$ port dir cairo

But the actual file is nowhere to be found. (locate gives nothing. Also, this command I found to list installed perl mods doesn't list it: )

Also, I've made sure I'm using the macports perl by changing the first line of the script to #!/opt/local/bin/perl and tried running it specifically from the command line as "/opt/local/bin/perl <script>"

I feel like I'm missing a major step somewhere, and would really appreciate some guidance.


More information about the macports-users mailing list