New user wants to write c code in Xcode

arvand tiv at
Thu Jun 17 11:43:23 PDT 2010

Hello to All

Rather annoying  error came to my attention when I noticed my gdb complains
even building a simple "hello World" c file with the following message in
Xcode console:


/Developer/usr/bin/gdb: line 88: sed: command not found
ERROR: No architecture specified with -arch argument.

The Debugger has exited with status 1.The Debugger has exited with status 1.


trying to trace back the problem I concluded that maybe my previous gdb
install job done through Macports could be the issue...
I tried to upgrade the gdb it failed. Then I tried to do a self update on
the Macports based I got the follwing error:


MacPorts base version 1.8.2 installed,
MacPorts base version 1.9.0 downloaded.
--->  MacPorts base is outdated, installing new version 1.9.0
Installing new MacPorts release in /opt/local as root:admin; permissions
0755; Tcl-Package in /Library/Tcl

Error: /opt/local/bin/port: port selfupdate failed: Error installing new
MacPorts base: shell command "cd /opt/local/var/macports/sources/ && ./configure --prefix=/opt/local
--with-tclpackage=/Library/Tcl --with-install-user=root
--with-install-group=admin --with-directory-mode=0755 --enable-readline &&
make && make install" returned error 1


can some one please let me know if I should uninstall macports in general or
if not how could I go about :
1. updating my gcc
2. if the problem I am experiencing in Xcode has anything to do with the
previous gcc/gdb install?

I would really appreciate any pointers


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list