Perl 5.8 dependency?

S.M. Protsman protsman at
Wed Mar 17 13:53:26 PDT 2010

It looks like all is well now. I applied the 'perl5 +perl5_10' variant  
then inadvertently uninstalled a number of ports while trying to fix  
the issue. I reinstalled most (the ones I thought I needed) and  
removed darcs. Lastly, I ran the following . . .

sudo port sync; sudo port selfupdate ; sudo port upgrade outdated

. . . and the perl5.8 situation has been resolved.

--->  Updating the ports tree
--->  Updating MacPorts base sources using rsync
MacPorts base version 1.8.2 installed,
MacPorts base version 1.8.2 downloaded.
--->  MacPorts base is already the latest version

The ports tree has been updated. To upgrade your installed ports, you  
should run
   port upgrade outdated
Error: No ports matched the given expression

I still don't know what the cause was, but at this point I am not  
concerned since the problem has vanished.


On Mar 17, 2010, at 1:25 PM, Daniel J. Luke wrote:

> You have likely found a bug (ports that need perl should almost  
> always be OK with either perl 5.10 or 5.8 being installed and  
> shouldn't need the other one).
> I don't know of a better way of figuring out which port is causing  
> you the problem other than manually.
> Take the output of 'port outdated' and search for the one that is  
> pulling in perl5.8 (you could take half of the list and try to  
> upgrade it and keep cutting it in half until you find the port  
> causing the problem - or you could just upgrade the ports one at a  
> time until you find the culprit).
> you probably also want to make sure you have perl5 +perl5_10  
> installed.
> On Mar 17, 2010, at 4:11 PM, S.M. Protsman wrote:
>> To make it interesting I ran the dependents command:
>> @naiad ~] port dependents perl5.8
>> perl5.8 has no dependents!
>> Hmmm...

More information about the macports-users mailing list