New user, port selfupdate error

Ryan Schmidt ryandesign at
Sat Mar 20 01:09:57 PDT 2010

On Mar 19, 2010, at 17:15, tome at QX.Net wrote:

> I am attempting to use macports for the first time.  I am not a computer science person, but do have limited experience with gcc and configure/make 
> installations.  I installed macports 1.7 from a disk image, with a successful completion message.  I then tried the second step of
> % sudo port -v selfupdate
> receiving the error shown in the below partial terminal output.
> My system is Mac PowerPC 750 ( pismo ) running OS X 10.4.11.
> Darwin Kernel Version 8.11.0
> Xcode 2.5
> gcc 4.0.1
> GNU make 3.81
> -----------------------------
> I have also tried the following, with the current port version 1.7, and received the indicated Error:
> % cd /opt/local/bin/portslocation/dports/faac
> % sudo port install faac
> Password:
> Error: Unable to execute port: invalid command name "livecheck.type"

The command "livecheck.type" is only available in MacPorts 1.8 and later. "sudo port selfupdate" should have updated you to the latest version of MacPorts, 1.8.2, unless rsync does not work on your network, in which case you need to manually install MacPorts 1.8.2 from the MacPorts 1.8.2 for Tiger disk image.

Wherever you were looking that suggested 1.7 is the current version is in error. Please check the only official source of information about MacPorts: the MacPorts web site at .

P.S: I can guess what site you were looking at that mentioned version 1.7, but I'm not going to mention the site here because I don't want to give it any more traffic. That site is not affiliated with the MacPorts project in any way and you should not refer to it for any information about MacPorts, nor donate any money to its operator. For more information, you can see:

More information about the macports-users mailing list