VLC Interface Error

Ryan Schmidt ryandesign at macports.org
Sun Oct 3 10:17:15 PDT 2010

On Oct 3, 2010, at 12:10, Jasper Frumau wrote:

> On Sun, Oct 3, 2010 at 8:25 PM, Ryan Schmidt wrote:
>> Have you tried double-clicking VLC in the /Applications/MacPorts folder? That would be the usual way to start VLC on Mac OS X.
> I did just now - thanks for that - and then I got these errors: http://pastebin.com/u32GxWWz  Any ideas what is going on here?

No, sorry. VLC is a large program that is difficult to compile. This is why VLC in MacPorts is stuck at version 1.0.6 instead of being updated to version 1.1.3:


And apparently even our 1.0.6 has problems, as you're discovering. Part of the problem is that VLC depends on libraries like ffmpeg and x264 which have not yet released stable versions and so are in a constant state of change; probably VLC 1.0.6 worked with the versions of ffmpeg and x264 we had in MacPorts at the time VLC 1.0.6 was released, but not with the newer versions of those libraries we now have in MacPorts. The errors you're seeing don't appear to be related to those libraries, but I just wanted to illustrate the types of problems we've had with the VLC port in the past.

You may be better off downloading the precompiled VLC from the VLC project itself:


More information about the macports-users mailing list