perl error when using modules

Ryan Schmidt ryandesign at
Mon Oct 4 18:13:59 PDT 2010

On Oct 4, 2010, at 19:37, Peng Yu wrote:

> When I run a perl program that calls SSLeay, I get the following
> error. I try to install SSLeay by 'cpan Net::SSLeay', but the problem
> is still not solved. Could you please let me know how to fix the
> problem?
> Can't load '/opt/local/lib/perl5/site_perl/5.8.9/darwin-2level/auto/Net/SSLeay/SSLeay.bundle'
> for module Net::SSLeay:
> dlopen(/opt/local/lib/perl5/site_perl/5.8.9/darwin-2level/auto/Net/SSLeay/SSLeay.bundle,
> 1): Library not loaded: /opt/local/lib/libssl.0.9.8.dylib
>  Referenced from:
> /opt/local/lib/perl5/site_perl/5.8.9/darwin-2level/auto/Net/SSLeay/SSLeay.bundle
>  Reason: image not found at
> /opt/local/lib/perl5/5.8.9/darwin-2level/ line 230.
> at line 88
> Compilation failed in require at line 88.
> BEGIN failed--compilation aborted at line 88.

So the problem is that the SSLeay.bundle installed by p5-net-ssleay is still linking with the old openssl 0.9.8 library. openssl was updated to 1.0.0 in July. p5-net-ssleay also received a revision bump at that time, so you should have been prompted to rebuild it to fix this. See:

Have you run "sudo port selfupdate" and "sudo port upgrade outdated" lately? If not, please do.

Note, you should not install perl modules using the cpan command; instead, you should install them using MacPorts. For example, as I hinted at above, the Net::SSLeay module is provided by the p5-net-ssleay port.

More information about the macports-users mailing list