Error: port activate failed: Registry error: No port of e installed.

John B Brown jbb at
Tue Oct 12 17:02:05 PDT 2010

On 10/12/10 5:34 PM, dgentry at wrote:
> Rainer,
> I installed Xcode successfully.
> When I ran "sudo port install apache2," I got:
> "sudo: /etc/sudoers is mode 0666, should be 0440
> Segmentation fault"
> I googled that result and then I ran "chmod 0440 /etc/sudoers."  The result was:
> "chmod: Unable to change file mode on /etc/sudoers: Operation not permitted."

	There are at least two "sure fire" methods of correcting any file 
"permissions" problems in Mac OS 10.6; run Disk Utility App or/and 
install the 10.6.4 combo update. The disk utility allows for detecting 
and correcting file permissions errors. The update generally corrects 
permissions errors in the file system. Whether it corrects /etc/sudoers 
I do not know, but the disk utility can and will make the changes 
without any arguments.

	Well, sort of, as with any automatic Apple computer process.

> _______________________________________________
> macports-users mailing list
> macports-users at


	John B. Brown.
	[jbb at]
	358 High Street,
	Buffalo, Wyoming

"Freedom is not worth having if it does not include
the freedom to make mistakes"  Mahatma Gandhi
"If any question why we died, tell them,
because our fathers lied."  Rudyard Kipling
"A man who does not know the truth is just an idiot
but a man who knows the truth and calls it a lie
is a crook."  Bertolt Brecht
"I wonder whether the world is being run
by smart people who are putting us on
or by imbeciles who really mean it."  Mark Twain


More information about the macports-users mailing list