=?utf-8?Q?Re=3A_llvm=3A_?=clang not included in 2.8?

Takashi Yoshida takashi at takashiyoshida.org
Tue Oct 12 20:10:41 PDT 2010

        Yeah, I just noticed the clang was removed in llvm 2.8_1. 
        -- Takashi YoshidaSent with Sparrow
        On Wednesday, October 13, 2010 at 9:36 AM, Ryan Schmidt wrote:
            On Oct 12, 2010, at 19:02, Takashi Yoshida wrote: That's strange. I just tried `which clang` and it came back with '/opt/local/bin/clang'.  I also tried running `port contents llvm` and it listed '/opt/local/bin/clang' among other things as well.  I had older clang installed from version 2.6_2 and 2.7_2 and recently upgraded it to 2.8_0.  Here's what I get when I run:  `port installed | grep llvm`    llvm @2.6_2   llvm @2.7_2   llvm @2.8_0+clang (active)  Strange part is that older versions do not have any variants listed (+clang) and when I upgraded to version 2.8, it appears like it picked up clang variant (which is not listed if you run `port info llvm`) automatically.  You can try installing the older version of llvm but you may also want to hear from the maintainers first.llvm @2.8_0 included a clang variant which was on by default.The variant and clang were removed from llvm in 2.8_1. You'll have to ask the maintainer what the plan is with that. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macosforge.org/pipermail/macports-users/attachments/20101013/ce373fef/attachment.html>

More information about the macports-users mailing list