selfupdate failed, help me diagnose the problem

John Korchok jkorchok at
Tue Apr 5 17:50:33 PDT 2011

Once I had this problem when my router was blocking one of required ports.
On another occasion I rebooted and it went away. A third time I just waited
awhile and tried again and it worked.

John Korchok 


From: macports-users-bounces at
[mailto:macports-users-bounces at] On Behalf Of Fredrik
Sent: Tuesday, April 05, 2011 5:40 PM
To: MacPorts Users
Subject: selfupdate failed, help me diagnose the problem


I got this recommendation when searching for a port: 

Warning: port definitions are more than two weeks old, consider using

When acting on this suggestion I got this output:

--->  Updating the ports tree
Error: Synchronization of the local ports tree failed doing rsync
Error: /opt/local/bin/port: port selfupdate failed: Couldn't sync the ports
tree: Synchronization of 1 source(s) failed

Any ideas where to go from here, to fix this?

Thank you

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list