GCC44 fails to build in MacOSXServer

Jason Swails jason.swails at gmail.com
Mon Apr 18 22:30:42 PDT 2011

On Mon, Apr 18, 2011 at 8:45 PM, Ryan Schmidt <ryandesign at macports.org>wrote:

> On Apr 18, 2011, at 21:15, Rodolfo Aramayo wrote:
> > I am getting the following error in MacOSXServer (Darwin 10.7.0 Darwin
> > Kernel Version 10.7.0: Sat Jan 29 15:16:10 PST 2011;
> > root:xnu-1504.9.37~1/RELEASE_X86_64 x86_64):
> [snip]
> > --->  Building gcc44
> [snip]
> > :info:build ../../gcc-4.4.6/gcc/fortran/module.c:108: error:
> > conflicting types for 'pointer_t'
> > :info:build /usr/include/mach/vm_types.h:40: note: previous
> > declaration of 'pointer_t' was here
> See this ticket:
> https://trac.macports.org/ticket/24541
> Two users there solved the problem by removing a symlink that they had
> manually created for some other reason.

This is probably unnecessary, but removing the malloc.h symlink I created in
/usr/include fixed this problem for me as well.  What I had been doing
before I learned about this fix was just comment out the definition of
pointer_t in /usr/include/mach/vm_types.h, which also worked (but I would
strongly suggest just removing the symlink).

What I've heard from C programmers is that malloc.h should rarely (never?)
be explicitly included anymore, anyway.  In any case, I think Apple omitted
that header from /usr/include for a reason.

All the best,

Jason M. Swails
Quantum Theory Project,
University of Florida
Ph.D. Candidate
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macosforge.org/pipermail/macports-users/attachments/20110418/6e9acc55/attachment.html>

More information about the macports-users mailing list