gcc-mp-4.4: error trying to exec '/opt/local/bin/i686-apple-darwin10-gcc-4.2.1': execvp: No such file or directory

Wolosh, Glenn woloshgm at umdnj.edu
Thu Aug 4 16:59:50 PDT 2011

On Aug 4, 2011, at 3:56 PM, Frank Schima wrote:

On Aug 4, 2011, at 11:57 AM, Wolosh, Glenn wrote:

I am running into the same error as this post --


I did not see any response to it.

If I use the full path to gcc, ie, /opt/local/bin/gcc I do not get the
error. If I just enter gcc on the command line I do get the error. I'm
not sure what is going on.

What's the output of the following?

which gcc

Then what's the output when you run "ls -l" with that path?

Also, run the port select command with the -d flag and post the output, namely:

sudo port -d select gcc mp-gcc44

Well, this is odd, when I opened a new terminal to get the output, the gcc command worked as expected. I tried a few more times and all is well. There must have been something screwy particular to the terminal I was working in.




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macosforge.org/pipermail/macports-users/attachments/20110804/a84acd59/attachment.html>

More information about the macports-users mailing list