p5-gd is replaced by p5.12-gd

Banana mail at bananas-playground.net
Thu Aug 25 00:50:11 PDT 2011

On 24.08.11 21:12, Ryan Schmidt wrote:
> You should not be seeing this error if your ports tree is up to date. Please "sudo port selfupdate" and try again.

This is not possible. I'm behind a proxy which only allows access via 
port 80.  I've setup macports to use 
"http://www.macports.org/files/ports.tar.gz [default]" since rsync is 
not allowed.

I use "port sync" to get the latest version of the ports tree. Did this 
5 Minutes ago and still get the error...

> On Aug 24, 2011, at 06:48, Jason Swails wrote:
>> I've seen it, but with help2man.  But it was complaining about a different p5.12 perl package.  I was going to hack the Portfile and take out the .12, since that was actually found in the port list...
>> I'd love to hear what the real problem is, though.
>> Thanks!
>> Jason
>> On Wed, Aug 24, 2011 at 5:07 AM, Banana<mail at bananas-playground.net>  wrote:
>> Hello everyone,
>> I just updated my macports tree (port -d sync) and tried to upgrade the outdated ports ( port upgrade outdated ).
>> When it comes to the p5-gd port it exits with the following error message (debug mode on):
>> DEBUG: epoch: in tree: 0 installed: 0
>> DEBUG: p5-gd 2.450.0_3 exists in the ports tree
>> DEBUG: p5-gd 2.45_2  is the latest installed
>> DEBUG: p5-gd 2.45_2  is active
>> DEBUG: Merging existing variants '' into variants
>> DEBUG: new fully merged portvariants:
>> --->   p5-gd is replaced by p5.12-gd
>> Error: No port p5.12-gd found.
>> To report a bug, see<http://guide.macports.org/#project.tickets>
>> Does anybody has this problem, too ?

More information about the macports-users mailing list