Subversion questions

james collins james.collins75 at
Fri Aug 26 11:52:00 PDT 2011

An update:

I was trying to install recoll, using macports.

I downloaded macports and ran the installer. I wasn't able to use selfupdate because I couldn't use rsync.

So I was following the wiki tutorial on how to use subversion to update the ports tree.

I believe I was able to get the port tree using subversion.

But my terminal wasn't able to properly sync my ports tree. I had edited sources.conf by adding the following line as per wiki instructions.

file:///opt/local/var/macports/sources/ [default]

But my macports wasn't syncing, I had all zereos. And macports wasn't recognizing recoll.

So I edited sources.conf by adding the line

file:///opt/local/var/macports/sources/ [default]

I tried that line because that was the directory where my port tree files were located.

Anyway when I ran the synced command again terminal added a lot of ports at the end I got the following from terminal

Total number of ports parsed: 12143
Ports successfully parsed: 12143
Ports failed: 0
Up-to-date ports skipped: 0

I then ran sudo port -d install recoll

And I was able to download and install recoll and it's dependencies.

I have a couple of questions:

Why did changing the path from the wiki article work? 

Did sync work correctly, why didn't terminal recognize the ports from the ports tree? 

It seemed to re-download the files from the ports tree?

When my macports recognized the install recoll command did it use subversion? Or did rsync just start working? Can you install a port without rsync?

Sent from my iPhone

More information about the macports-users mailing list