ipython and readline

Frank Schima macsforever2000 at macports.org
Mon Dec 5 10:41:44 PST 2011

On Dec 5, 2011, at 11:06 AM, Jean-François Caron wrote:

> This happened after my latest round of selfupdate and upgrade outdated.  Previously ipython worked with no problems, but now if I start it up, I get an error message about readline, and something about libedit coming from Leopard (I am running Lion).  It recommends that I install readline, which is already installed from macports.  After the error message, I get an ipython prompt but the prompt itself is screwed up.  The regular python interpreter has no problems.  
> See below for my terminal output when I tried the various commands.
> jfcaron at jfcaron-macbook:~$ ipython
> /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/IPython/utils/rlineimpl.py:96: RuntimeWarning: Leopard libedit detected - readline will not be well behaved including some crashes on tab completion, and incorrect history navigation. It is highly recommended that you install readline, which is easy_installable with: 'easy_install readline'
> RuntimeWarning)
> Python 2.7.2 (default, Dec  3 2011, 17:24:13) 
> Type "copyright", "credits" or "license" for more information.
> IPython 0.11 -- An enhanced Interactive Python.
> ?         -> Introduction and overview of IPython's features.
> %quickref -> Quick reference.
> help      -> Python's own help system.
> object?   -> Details about 'object', use 'object??' for extra details.
> 34In[1;3[0;34][0^D
> Do you really want to exit ([y]/n)? y
> jfcaron at jfcaron-macbook:~$ port installed|grep readline
> readline @6.2.000_0+universal (active)
> jfcaron at jfcaron-macbook:~$ python
> Python 2.7.2 (default, Dec  3 2011, 17:24:13) 
> [GCC 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00)] on darwin
> Type "help", "copyright", "credits" or "license" for more information.
>>>> ^D
> Any suggestions would be appreciated, I'm hoping it's a simple "select" command that I need to issue, but it's strange that doing the regular port upgrade outdated would have broken this program.

What is the output of the following?

	port installed py27-readline


More information about the macports-users mailing list