Does gcc45 support -arch?

Peng Yu pengyu.ut at
Sat Dec 17 21:42:40 PST 2011

On Sat, Dec 17, 2011 at 11:27 PM, Ryan Schmidt <ryandesign at> wrote:
> On Dec 17, 2011, at 23:25, Peng Yu wrote:
>> I have gcc45 active. After run configure, I run make make, then I got
>> error in the Perl directory. The problem is that the following
>> automatically generated file has the -arch argument. I don't want to
>> change it manually as it is automatically generated.
>> ./Perl/Makefile.perl:44:LDFLAGS =  -Wl,-search_paths_first -arch i386
>> -arch x86_64 -Wl,-syslibroot,/Developer/SDKs/MacOSX10.5.sdk
>> -mmacosx-version-min=10.5 -fstack-protector
> Sounds like
> which was just fixed. Have you already run "sudo port selfupdate" and "sudo port upgrade outdated"?

I have daily updated automatically running. So my system should be
updated. I just tried it again. Does the error at the end mean the
install is up to date?

~$ sudo sudo port selfupdate
--->  Updating MacPorts base sources using rsync
MacPorts base version 2.0.3 installed,
MacPorts base version 2.0.3 downloaded.
--->  Updating the ports tree
--->  MacPorts base is already the latest version

The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated
~$ sudo port upgrade outdated
Error: No ports matched the given expression


More information about the macports-users mailing list