Please send contents of current mysqld file

David Gentry localbusinesswebsites at
Mon Mar 14 12:48:34 PDT 2011


I don't trust my memory to put the files I moved back to their origins, so I uninstalled mysql5 @5.1.55_0 and mysql5-server @5.1.55_0.  Then I installed them.

Then, following the installation directions, I ran sudo port load mysql5-server.  Then, again following the directions, I ran sudo -u _mysql mysql_install_db5 with this result:

FATAL ERROR: Could not find mysqld

The following directories were searched:


If you compiled from source, you need to run 'make install' to
copy the software into the correct location ready for operation.

If you are using a binary release, you must either be at the top
level of the extracted archive, or pass the --basedir option
pointing to that location.

Then, following the wiki which says if that command does not work try sudo mysql5_install_db5, I ran it with the same result as above.

Then I tried this command: sudo -u mysql mysql_install_db5 with the same result as above.  This is the command from the wiki.  The command in the terminal installation directions is slightly different: sudo -u _mysql mysql_install_db5.

Then, just for fun, I followed the wiki to see if the server is running.  I ran ps -ax | grep mysql.  The result was:

 5406 ??         0:00.02 /opt/local/bin/daemondo --label=mysql5 --start-cmd /opt/local/etc/LaunchDaemons/org.macports.mysql5/mysql5.wrapper start ; --stop-cmd /opt/local/etc/LaunchDaemons/org.macports.mysql5/mysql5.wrapper stop ; --restart-cmd /opt/local/etc/LaunchDaemons/org.macports.mysql5/mysql5.wrapper restart ; --pid=none
 5875 ttys000    0:00.00 grep mysql

I have never run that command, but I see no error messages, so I suspect the server is running.

Thanks for your patience, and I would appreciate any ideas you have.

On Mar 13, 2011, at 5:17 PM, Ryan Schmidt wrote:

On Mar 10, 2011, at 15:10, David Gentry wrote:

> Bayard,
> I am responding to your message:
>> "It's not really clear what leads you to suspect corruption in the first instance. Perhaps we might start with how you get to that conclusion and work out a shared understanding of the problem on that basis?"
> Please refer to my reply to raimue at which is message 10 is the list of March 9, 2011.  If you don't have that message 10, I would be happy to repeat it for you.

David, I assume you're referring to this message:

There, all you showed was that mysql_install_db5 was unable to find mysqld in directories under /usr/local/mysql-5.5.6-rc-osx10.6-x86_64. Those directories are where an official installation of mysql would have put files, so that's not the correct place for a MacPorts mysql to be searching for things, and you already said you deleted all files there, so it's no surprise it can't find it there. This does not indicate mysqld is corrupt; it indicates mysql_install_db5 is searching for mysqld in the wrong places. We need to figure out why it's doing that.

Following that, you started moving MacPorts-installed files around, which should not be necessary for success, so I'm not going to deal with anything past that point. Put all MacPorts-installed files back where they were, then we can investigate further.

David J. Gentry
Good Things -- Small Packages, LLC
dgentry at

More information about the macports-users mailing list