Problem with install

Ed Keith e_d_k at
Wed Mar 30 17:53:08 PDT 2011

First I should say that I am new to Mac.

I tried to install pure-gen. After 6 hours I had to abort the install. Later,
when I had more time I decided to try again, but it very quickly gave an error. I have tried running "sudo port clean pure-gen" but it does not seem to do anything. I believe this is a copy of the relevant portion of the log:

:msg:main --->  Building pure-gen
:debug:build build phase started at Wed Mar 30 08:46:07 EDT 2011
:debug:build Executing
:debug:build Executing (pure-gen)
:debug:build Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_pure-gen/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6'
:debug:build Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_pure-gen/work/pure-gen-0.10" && /usr/bin/make -j5 all LIBRARY_PATH=/opt/local/lib CC=/usr/bin/gcc-4.2 CFLAGS="-O2" CPPFLAGS="-I/opt/local/include" CXX=/usr/bin/g++-4.2 CXXFLAGS="-O2" LDFLAGS="-L/opt/local/lib"'
:info:build sed -e 's?@version@?0.10?' -e 's?./dump-ast?/opt/local/lib/pure-gen/dump-ast?' < pure-gen.pure > xxpure-gen.pure
:info:build pure -c xxpure-gen.pure -o pure-gen
:info:build LLVM ERROR: Cannot yet select: 0x10207f510: f64 = sint_to_fp 0x1020a9e10 [ORD=1367] [ID=25]
:info:build   0x1020a9e10: i32,ch = load 0x10191a398, 0x102081c10, 0x1022cab10<LD4[%291]> [ORD=1366] [ID=23]
:info:build     0x10191a398: ch = EntryToken [ORD=1364] [ID=0]
:info:build     0x102081c10: i64 = add 0x1020b8910, 0x1020b9010 [ORD=1364] [ID=21]
:info:build       0x1020b8910: i64,ch = CopyFromReg 0x10191a398, 0x102081710 [ORD=1364] [ID=17]
:info:build         0x10191a398: ch = EntryToken [ORD=1364] [ID=0]
:info:build         0x102081710: i64 = Register %reg16384 [ORD=1364] [ID=1]
:info:build       0x1020b9010: i64 = Constant<8> [ORD=1364] [ID=2]
:info:build     0x1022cab10: i64 = undef [ORD=1366] [ID=3]
:info:build make: *** [pure-gen] Error 1

Can anyone give me a hint how to fix this?

Thank you,


Ed Keith
e_d_k at


More information about the macports-users mailing list