Problem with install

Ryan Schmidt ryandesign at
Thu Mar 31 07:57:32 PDT 2011

On Mar 30, 2011, at 19:53, Ed Keith wrote:

> First I should say that I am new to Mac.


> I tried to install pure-gen. After 6 hours I had to abort the install.

Do you recall what exactly it said before you aborted? (What phase of what port was it in when you aborted?) How did you abort? (Control-C in the Terminal? Something else?)

> Later,
> when I had more time I decided to try again, but it very quickly gave an error. I have tried running "sudo port clean pure-gen" but it does not seem to do anything.

"sudo port clean pure-gen" should definitely do something: it should clean the pure-gen port. But it could certainly be that that does not fix the problem.

> I believe this is a copy of the relevant portion of the log:
> :msg:main --->  Building pure-gen
> :debug:build build phase started at Wed Mar 30 08:46:07 EDT 2011
> :debug:build Executing
> :debug:build Executing (pure-gen)
> :debug:build Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_pure-gen/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6'
> :debug:build Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_pure-gen/work/pure-gen-0.10" && /usr/bin/make -j5 all LIBRARY_PATH=/opt/local/lib CC=/usr/bin/gcc-4.2 CFLAGS="-O2" CPPFLAGS="-I/opt/local/include" CXX=/usr/bin/g++-4.2 CXXFLAGS="-O2" LDFLAGS="-L/opt/local/lib"'
> :info:build sed -e 's?@version@?0.10?' -e 's?./dump-ast?/opt/local/lib/pure-gen/dump-ast?' < pure-gen.pure > xxpure-gen.pure
> :info:build pure -c xxpure-gen.pure -o pure-gen
> :info:build LLVM ERROR: Cannot yet select: 0x10207f510: f64 = sint_to_fp 0x1020a9e10 [ORD=1367] [ID=25]
> :info:build   0x1020a9e10: i32,ch = load 0x10191a398, 0x102081c10, 0x1022cab10<LD4[%291]> [ORD=1366] [ID=23]
> :info:build     0x10191a398: ch = EntryToken [ORD=1364] [ID=0]
> :info:build     0x102081c10: i64 = add 0x1020b8910, 0x1020b9010 [ORD=1364] [ID=21]
> :info:build       0x1020b8910: i64,ch = CopyFromReg 0x10191a398, 0x102081710 [ORD=1364] [ID=17]
> :info:build         0x10191a398: ch = EntryToken [ORD=1364] [ID=0]
> :info:build         0x102081710: i64 = Register %reg16384 [ORD=1364] [ID=1]
> :info:build       0x1020b9010: i64 = Constant<8> [ORD=1364] [ID=2]
> :info:build     0x1022cab10: i64 = undef [ORD=1366] [ID=3]
> :info:build make: *** [pure-gen] Error 1
> Can anyone give me a hint how to fix this?

Hmm, that's new to me! Is this on one of the very new Macs? If so, perhaps the current version of LLVM is not compatible with it. LLVM 2.9 is scheduled to be released April 4; perhaps that will help.

Pure 0.47 was just released a few hours ago, along with new versions of most of the modules, including pure-gen; I hope to have this committed within a few days. You can try that then to see if it makes a difference. You could also try rebuilding llvm, on the off chance that you interrupted the build of llvm earlier, and that this caused a problem of some kind.

sudo port clean llvm
sudo port -n upgrade --force llvm

More information about the macports-users mailing list