sudo port selfupdate fails

Ryan Schmidt ryandesign at
Tue Sep 6 13:41:16 PDT 2011

On Sep 6, 2011, at 08:41, Johannes Ruscheinski wrote:

> On 5 September 2011 21:48, Ryan Schmidt wrote:
>> On Sep 5, 2011, at 23:40, Johannes Ruscheinski wrote:
>>> After doing a "sudo port uninstall mono" I still get the same error.
>>> My build still prints out:
>>> base32cmd.o sha1cmd.o curl.o rmd160cmd.o sha256cmd.o readline.o uid.o
>>> tracelib.o tty.o readdir.o pipe.o flock.o system.o mktemp.o realpath.o
>>> -o Pextlib.dylib
>>> -L/System/Library/Frameworks/Tcl.framework/Versions/8.5 -ltclstub8.5
>>> -lcurl  -lreadline
>>> ===> making all in src/registry2.0
>>> /usr/bin/llvm-gcc-4.2 -c -DUSE_TCL_STUBS -DTCL_NO_DEPRECATED -g -O2 -W
>>> -Wall -pedantic
>>> -I/Library/Frameworks/Mono.framework/Versions/2.2/include
>>> -DHAVE_CONFIG_H -I.. -I.  -I"/usr/include" -fno-common registry.c -o
>>> registry.o
>>> In file included from ../cregistry/registry.h:35,
>>>                 from registry.c:39:
>>> How can I identify the problematic port in order to uninstall it?   Thanks!
>> It is not a port. It is a standalone installation of Mono, installed by a means other than MacPorts.
> Ok, so how can I remove it?

You'll have to ask them; I don't know where all it put its files. At minimum, remove /Library/Frameworks/Mono.framework and /usr/bin/pkgconfig.

> And why is MacPorts picking up on it?
> Something in my PATH that I need to remove?

Because they installed /usr/bin/pkgconfig pointing to their own pkgconfig. MacPorts and other software will query pkgconfig if present and use its results to determine where to find libraries. It is an error for them to have installed /usr/bin/pkgconfig.

Meanwhile, we hope to work around this problem in a future version of MacPorts by no longer querying pkgconfig, since we know Mac OS X does not come with pkgconfig and that we can find the libraries without it.

More information about the macports-users mailing list