Can't build ffmpeg

Richard L. Hamilton rlhamil at
Thu Sep 8 09:06:16 PDT 2011

I just tried
sh-3.2# port install ffmpeg configure.compiler=gcc-4.2

(instead of the default, which I suppose is llvm-gcc4.2) and it worked.  For me, that nails that it's at least in part the compiler (not that a source workaround might not be possible, and perhaps even better if llvm generates better code).

On Sep 7, 2011, at 9:04 AM, Dominik Reichardt wrote:

> I reported that three hours ago
> :)
>> Log attached.  Warnings may be source issues, but the final failure looks like a compiler problem to me.
>> <>_______________________________________________
>> macports-users mailing list
>> macports-users at

The waitress asked, "Do you want lemon or no lemon with that iced tea?"
Naturally, I said "yes", and then burst out laughing, because there simply
wasn't any other answer in Boolean logic.  She didn't get it, but I got
the lemon, which I wanted anyway.  Later, I realized a quantum computer
could have offered another answer: Schroedinger's Lemon!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list