gtk3 quartz install failure

Thomas Stover cts at
Fri Aug 3 14:17:25 PDT 2012

hi list

First I installed the default x11 gtk3, which worked fine. Then I
wanted to test the quartz version, which evidently can not be
simultaneously installed :(

So after the first batch of errors, I tried to start over with:
$ sudo port -fp uninstall installed

$ sudo port install gtk3 +quartz

which yielded:
Error: Please uninstall or deactivate the pango port and reinstall it
by running `port install pango +no_x11`.

So I tried

$ sudo port uninstall pango
$ sudo port install pango +no_x11

which gives
Error: To install pango without the quartz variant, cairo must be
installed without the quartz variant.
$ sudo port uninstall cairo
Error: port uninstall failed: Please uninstall the ports that depend on
cairo first.

I think I'm going in a circle. Any ideas? How would I tell it to
uninstall all the cairo deps - even though I uninstalled everything to
start with?


More information about the macports-users mailing list