many macports builds simply die on new, clean Mtn Lion install

John Daschbach jldasch at
Fri Aug 31 08:35:22 PDT 2012

I have been struggling with building many macports on a late 2009 iMac which came back from Apple yesterday with a new hard drive (thanks AppleCare, 1 mo short of expiration!)  A totally clean machine.  I loaded the latest Xcode and command line tools.  I also have installed R from, including gfortran and tck/tk.  

Posting to the bug tracking list may not be appropriate because what I understand of the problem is not exactly a macports problem.

Many builds simply hang, almost always during configuration.  port reports "Configuring ..." and then stays there indefinitely.    Checking main.log for the build shows nothing.  Looking in the build directory t the config.log always shows unfinished output.  Perhaps the most telling item is that the config.log almost always terminates part way through a write to disk, i.e. the last message is incomplete and not terminated with a newline.    It seems pretty clear that clang is related to the problem as the output termination is always during a configure phase were test snippets are being executed by clang.   But configure is a bash script and it is generating the output.

The hangs appear consistent, that is they always happen at the same point and with the same output.   This makes a bad memory region seem less likely, and memory was tested at Apple 2 days ago, and nothing else is a problem.    Also, I wrote a perl script that uses variable amounts of memory (checked with top -o rsize) and the place at which the configure script hangs is always the same regardless of how much memory is free or available (presumably moving everything around in memory).

However, for the ports I have tried to build by hand, building has worked.  For instance both python27 and python33 hang in configure, but if I go to the work directory and execute the standard ./configure;make;make test;make install sequence they install fine (in /usr/local).  This is confusing, because except for the memory region argument I'm not sure why configure should hang called from tcl in macports 

I installed the llvm compiler via macports and specified that as an option for builds and it fails.  Trying to build apple-gcc42 has not worked as there is a required library that is built with clang that hangs during build.  This is also telling, as it is an xcode project, and there is no configure or make phase.   Trying to run it in xcode has not worked yet as the paths for some includes appear broken.

Changing the compiler option in macports on the install command changes where configure crashes (e.g. compiler=gcc vs compiler=llvm-gcc42) but remains consistent for either with respect to itself over many invocations.

I'm watching the system log and can't find anything related to a crash in clang or llvm or a seg fault or similar from anything.

It really seems like clang is the problem and likely that it's some kind of memory issue in clang.   Very frustrating.

Any ideas?


More information about the macports-users mailing list