compiling for 32bit on a 64bit machine

Ryan Schmidt ryandesign at
Thu Dec 27 17:35:05 PST 2012

On Dec 27, 2012, at 19:03, Ben Martin <monkeyiq at> wrote:

>  I have a macport of fontforge from git which I can build and run just
> fine on a Mountain Lion machine. I'm trying to broaden the compatibility
> list for the generated pkg to allow a wider range of users to install
> the generated binary.
>  First up I added:
> macosx_deployment_target  10.6
>  Then I discovered somebody getting an "Illegal instruction" error and
> this would seem to be that they are running on a Mac-Book-Pro
> root:xnu-1504.15.3~1/RELEASE_I386 i386.
>  So then I tried adding to my macports.conf file:
> build_arch   i386

I'd recommend keeping build_arch at x86_64, and setting universal_archs to i386 x86_64 (should already be set that way) and then building ports with the +universal variant.

However, setting build_arch i386 should have worked and you should not have encountered an error

> ld: warning: ignoring file .libs/splinerefigure.o, file was built for
> unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3
> 0x 0 0x 0 0x 0 0x 1 0x 0 0x 0 0x 0 ) which is not the architecture being
> linked (i386): .libs/splinerefigure.o

This kind of thing has appeared often; you can search the issue tracker. I don't remember what the ultimate solution turned out to be, or if there even was one.

More information about the macports-users mailing list