Aspell question?

William H. Magill magill at
Sat Dec 29 15:31:52 PST 2012

This is probably strictly an Aspell question, not mac ports...
I'm a long time ispell user converting to Aspell.   I've installed Aspell and its dictionary via mac ports.

(This is also on a new (Black Thursday) Mac-mini with OSX 10.8.2 and OSX Server 2.2)

sudo port install aspell
sudo port install aspell-dict-en

both apparently installed with no errors.

to my .emacs file, I've added:
  (setq-default ispell-program-name "aspell")
  (setq-default ispell-extra-args '("--reverse"))

I ran "aspell-import
( that process complained about /M and similar inclusions in my .ispell_english file, which surprised me.)

Now, when I run ispell on my emacs buffer, I get:

"Error: /Users/magill/.aspell.en.pws: The word "personal_ws-1.1 en 635 " is invalid. The character '_' (U+5F) may\
 not appear in the middle of a word."

This is "sort of true" -- that is the header line created by aspell, and is as is documented at

So the question is: Which is it... an issue with the macports aspell installation or an issue with aspell itself?

William H. Magill
# iMac11,3 Core i7 [2.93GHz - 8 GB 1067MHz] OS X 10.8.2
# MacBook Pro4.1 Core 2 Duo [2.5GHz - 4GB 667] OS X 10.6.8
# Macmini6,1 Intel Core i5 [2.5 Ghz - 4GB 1600MHz] OS X 10.8.1

magill at
whmagill at

More information about the macports-users mailing list