Question about Xcode 4.2.1 on Lion

Jeff Singleton gvibe06 at
Sun Feb 5 14:42:59 PST 2012

Thanks Ryan

I double checked everything and everything appears correct in regards to
Path.  I reinstalled Xcode 4.2.1 and the Combo 10.7.3 update, fixed
permissions etc etc.

I am building llvm-gcc42 now, which seems to be going much better.

Once this is done, I will attempt gcc43 again….the only reason I am using
gcc43 is because I am developing for Android and the SDK seems to like
gcc43 better, however, gcc46 also has some positives, so I may build that
as well.

I will let the list know when all is done and whether I opened a bug.


On Sun, Feb 5, 2012 at 4:17 PM, Ryan Schmidt <ryandesign at>wrote:

> On Feb 5, 2012, at 13:56, Jeff Singleton wrote:
> > Ok so I got past git-core, but now no version of GCC will install.  I
> have tried gcc43, gcc44, gcc45, and finally, skipping gcc46, I tried gcc47.
>  All of them fail to build with the same errors:
> >
> > checking for library containing strerror... make[2]: ***
> [configure-build-libiberty] Error 1
> > make[2]: *** Waiting for unfinished jobs....
> > none required
> > checking how to run the C preprocessor... /lib/cpp
> > configure: error: in
> `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc47/gcc47/work/build/libiberty':
> > configure: error: C preprocessor "/lib/cpp" fails sanity check
> > See `config.log' for more details.
> This is not an uncommon error message; we've fixed it in many other ports
> before. If you get the same after cleaning and trying again, file a bug
> report in the issue tracker so it can be investigated and fixed. Be sure to
> attach the full main.log file, as well as the aforementioned config.log
> file.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list