Help with Lion's symbolic links

M A markoilcan at
Tue Feb 7 08:24:08 PST 2012

On Mon, Feb 6, 2012 at 11:03 PM, Justin C. Walker <justin at> wrote:
> On Feb 6, 2012, at 18:40 , M A wrote:
>> I apologize for raising an issue that is not specific to macports, but
>> Google hasn't provided me an answer. In any case, after upgrading my
>> system to Lion I find that I can no longer save to symbolic links to a
>> directory in standard Mac GUI applications.
> Just tried this with 10.7.1 on my laptop.  I created a directory in /tmp; sym-linked it to another in /tmp; created a file in TextEdit; and then saved it to the sym-linked directory w/o a problem.
> What version of 10.7?  What does "ls -ld" show for dir_orig and dir_link?
> Is "word" (I assume that's the app you used) "fully 10.7-aware" [whatever that may mean]?  Have you tried it with TextEdit?  Any other apps?

This is on 10.7.3. By the sounds of it, it seems like this may not
have been a problem before 10.7.2. After doing some more testing, it
seems to be a problem in MS Word and an app called Sketchpad, but
don't seem to be a problem with TextEdit, Aquamacs, Preview and
Firefox. So, I guess this is a problem with only certain applications.
As Aljaž mentions, in some of the apps where it does work, the sym
link icon is grayed out, but it still resolves correctly once
selected. Anyway, I guess this would seem to be an application
specific bug rather than a major OS bug.

Mark A

More information about the macports-users mailing list