Issues doing a port upgrade with Xcode 4.3

Aljaž Srebrnič a2piratesoft at
Fri Feb 17 06:06:36 PST 2012

Just read this, especially the part "Upgrading to Xcode 4.3"

Aljaž Srebrnič
-- --
My public key:

On 17/feb/2012, at 15:04, Stefan Scheidt wrote:

> Hi,
> I'm using OS X 10.7.3 and MacPorts 2.0.3.
> I just upgraded to Xcode 4.3 and now have problems doing a "sudo port upgrade outdated".
> Here's what I did:
> (1) Install Xcode 4.3 via App Store
> (2) Move /Developer to trash by Xcode 4.3 after first start of Xcode 4.3
> (3) Download Command Line Tools via Xcode 4.3 preferences
> (4) tried a "sudo port upgrade outdated", causing a "Warning: xcodebuild exists but failed to execute" and a "Error: Target org.macports.configure returned: configure failure: shell command failed" while port tried to upgrade serf1
> (5) "sudo /usr/bin/xcode-select -switch /Applications/"
> Now I get:
> --->  Computing dependencies for serf1
> --->  Configuring serf1
> Error: Target org.macports.configure returned: configure failure: shell command failed (see log for details)
> Log for serf1 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_serf1/serf1/main.log
> Error: Unable to upgrade port: 1
> To report a bug, see <>
> In main.log I found various references of "/Developer". Find main.log attached. I tried to symlink /Developer to /Applications/ but that didn't help.
> Any ideas?
> Regards
> Stefan
> version:1
> :msg:main ---> Computing dependencies for serf1:info:main .:debug:main Searching for dependency: apr
> :debug:main Found Dependency: receipt exists for apr
> :debug:main Searching for dependency: apr-util
> :debug:main Found Dependency: receipt exists for apr-util
> :debug:main Searching for dependency: openssl
> :debug:main Found Dependency: receipt exists for openssl
> :msg:main 
> :debug:main Executing org.macports.main (serf1)
> :debug:main Skipping completed org.macports.archivefetch (serf1)
> :debug:main Skipping completed org.macports.fetch (serf1)
> :debug:main Skipping completed org.macports.checksum (serf1)
> :debug:main Skipping completed org.macports.extract (serf1)
> :debug:main Skipping completed org.macports.patch (serf1)
> :debug:configure configure phase started at Fri Feb 17 14:28:00 CET 2012
> :notice:configure ---> Configuring serf1
> :debug:configure Using compiler 'Mac OS X clang'
> :debug:configure Executing org.macports.configure (serf1)
> :debug:configure Environment: CPATH='/opt/local/include' CFLAGS='-O2 -arch x86_64' CPPFLAGS='-I/opt/local/include' CXXFLAGS='-O2 -arch x86_64' LIBRARY_PATH='/opt/local/lib' MACOSX_DEPLOYMENT_TARGET='10.7' CXX='/Developer/usr/bin/llvm-g++-4.2' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_serf1/serf1/work/.CC_PRINT_OPTIONS' F90FLAGS='-O2 -m64' LDFLAGS='-L/opt/local/lib -arch x86_64' OBJC='/Developer/usr/bin/clang' FCFLAGS='-O2 -m64' INSTALL='/usr/bin/install -c' OBJCFLAGS='-O2 -arch x86_64' FFLAGS='-O2 -m64' CC_PRINT_OPTIONS='YES' CC='/Developer/usr/bin/clang'
> :debug:configure Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_serf1/serf1/work/serf-1.0.1" && ./configure --prefix=/opt/local --with-apr=/opt/local/bin/apr-1-config --with-apr-util=/opt/local/bin/apu-1-config'
> :debug:configure Executing command line: cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_serf1/serf1/work/serf-1.0.1" && ./configure --prefix=/opt/local --with-apr=/opt/local/bin/apr-1-config --with-apr-util=/opt/local/bin/apu-1-config 
> :info:configure checking for chosen layout... Serf
> :info:configure checking for working mkdir -p... yes
> :info:configure checking build system type... i386-apple-darwin11.3.0
> :info:configure checking host system type... i386-apple-darwin11.3.0
> :info:configure checking target system type... i386-apple-darwin11.3.0
> :info:configure 
> :info:configure Configuring Apache Portable Runtime library...
> :info:configure 
> :info:configure checking for APR... yes
> :info:configure setting CPP to "/Developer/usr/bin/clang -E"
> :info:configure setting APR_LIBTOOL to "/opt/local/share/apr-1/build/libtool"
> :info:configure adding "-DDARWIN" to CPPFLAGS
> :info:configure adding "-DSIGPROCMASK_SETS_THREAD_MASK" to CPPFLAGS
> :info:configure adding "-no-cpp-precomp" to CPPFLAGS
> :info:configure setting LTFLAGS to "--silent"
> :info:configure 
> :info:configure Configuring Apache Portable Runtime Utility library...
> :info:configure 
> :info:configure checking for APR-util... yes
> :info:configure adding "-L/opt/local/lib/db46" to LDFLAGS
> :info:configure checking for gcc... /Developer/usr/bin/clang
> :info:configure checking for C compiler default output file name... 
> :info:configure configure: error: C compiler cannot create executables
> :info:configure See `config.log' for more details.
> :info:configure shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_serf1/serf1/work/serf-1.0.1" && ./configure --prefix=/opt/local --with-apr=/opt/local/bin/apr-1-config --with-apr-util=/opt/local/bin/apu-1-config " returned error 77
> :error:configure Target org.macports.configure returned: configure failure: shell command failed (see log for details)
> :debug:configure Backtrace: configure failure: shell command failed (see log for details)
> while executing
> "$procedure $targetname"
> :info:configure Warning: the following items did not execute (for serf1): org.macports.install org.macports.configure org.macports.destroot
> :notice:configure Log for serf1 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_serf1/serf1/main.log
> _______________________________________________
> macports-users mailing list
> macports-users at

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list