Issues doing a port upgrade with Xcode 4.3

Stefan Scheidt stefan.scheidt at
Fri Feb 17 08:55:21 PST 2012

Hi Eric,

thanks for the quick response. Your hint was quite a success, but now I still get stuck with subversion-perlbindings

$ sudo port upgrade outdated
--->  Computing dependencies for subversion-perlbindings
--->  Fetching archive for subversion-perlbindings
--->  Attempting to fetch subversion-perlbindings-1.7.3_0.darwin_11.x86_64.tgz from
--->  Fetching subversion-perlbindings
--->  Verifying checksum(s) for subversion-perlbindings
--->  Extracting subversion-perlbindings
--->  Computing dependencies for subversion-perlbindings
--->  Building subversion-perlbindings
Error: Target returned: shell command failed (see log for details)
Log for subversion-perlbindings is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion-perlbindings/subversion-perlbindings/main.log
Error: Unable to upgrade port: 1

Any idears how to fix this? I really would like to avoid reinstalling macports and all ports...

I'll attach subversion-perlbindings/main.log, which still shows refs to /Developer...

By the way, I also followed the migration instructions:

`sudo xcode-select -switch /Applications/`

and changed macports.conf developer_dir setting.


Am 17. Feb 2012 um 15:28 schrieb Eric Cronin <ecronin at>:

On 17.02.2012 09:04, Stefan Scheidt wrote:
> Hi,
> I'm using OS X 10.7.3 and MacPorts 2.0.3.
> I just upgraded to Xcode 4.3 and now have problems doing a "sudo port
> upgrade outdated".
> Here's what I did:
> (1) Install Xcode 4.3 via App Store
> (2) Move /Developer to trash by Xcode 4.3 after first start of Xcode
> 4.3
> (3) Download Command Line Tools via Xcode 4.3 preferences
> (4) tried a "sudo port upgrade outdated", causing a "Warning:
> xcodebuild exists but failed to execute" and a "Error: Target
> org.macports.configure returned: configure failure: shell command
> failed" while port tried to upgrade serf1
> (5) "sudo /usr/bin/xcode-select -switch
> /Applications/"
> Now I get:
> ---> Computing dependencies for serf1
> ---> Configuring serf1


port -n upgrade --force apr

and then try updating serf1 again. serf1 is using apr to get the path
to cc, and apr has an outdated path cached that no longer exists.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: main.log
URL: <>

More information about the macports-users mailing list