unable to compile libxml2 with Xcode 4.4

Ryan Schmidt ryandesign at macports.org
Sat Feb 18 14:30:00 PST 2012

On Feb 18, 2012, at 16:01, Artemio Gonzalez Lopez wrote:

> I just did that ("port version" reports now 2.0.99), but I run into the same error:
> EBUG: sed: RE error: illegal byte sequence
>    while executing
> "exec /usr/bin/sed s|/etc|/opt/local/etc|g < /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_te..."
>    ("eval" body line 1)
>    invoked from within
> "eval exec $cmdline"
> Error: reinplace: sed: RE error: illegal byte sequence
> Error: Target org.macports.extract returned: reinplace sed(1) failed
> DEBUG: Backtrace: reinplace sed(1) failed
>    while executing
> "$post $targetname"
> Any further ideas or suggestions?

In that case, see this comment jeremyhu left in the libxml2 portfile recently:


In other words, run "port edit libxml2" and I think change "reinplace" to "reinplace -locale C".

More information about the macports-users mailing list