gtk2 fails to build

Ryan Schmidt ryandesign at
Thu Jul 5 18:39:34 PDT 2012

On Jul 4, 2012, at 12:07, Thomas wrote:

> On Wed, Jul 4, 2012 at 5:59 PM, Ryan Schmidt <ryandesign at> wrote:
> > :info:build failed to load "./apple-red.png": Failed to load image './apple-red.png': reason not known, probably a corrupt image file
> This sounds very familiar:
> Try rebuilding gdk-pixbuf2:
> sudo port clean gdk-pixbuf2
> sudo port -n upgrade --force gdk-pixbuf2
> Ok, so I rebuilt gdk-pixbuf2 @2.26.1_1 (which I had built without problems just before) and then rebuilt (or indeed, upgraded to 2.24.10_2) gtk2 (after cleaning it again) but it still doesn't work - the same error, as far as I can tell.
> I have libpng @1.4.11_0, which seems to be the most recent port available. Would it make sense to force-rebuild that as well, or do you have other suggestions?

I Googled the error message and got this:

It suggests that although you have libpng 1.4.11 installed, perhaps some of the other ports you have installed that need libpng have not been rebuilt and are still linking with the old libpng 1.2.x. Does that seem possible? We upgraded to libpng 1.4.x a long time ago in MacPorts so you really shouldn't have anything left using libpng 1.2.x.

We have a script floating around somewhere to help you find things still linked with old libpng. Actually, these days rev-upgrade should find and rebuild them automatically. What happens if you run:

sudo port rev-upgrade

More information about the macports-users mailing list