git bash_completion does not work - solved (?)

Barrie Stott zen146410 at
Sat Jul 21 02:53:31 PDT 2012

On 20 Jul 2012, at 16:08, Clemens Lang wrote:

> On Fri, Jul 20, 2012 at 09:56:24AM -0500, Ryan Schmidt wrote:
>> I am still not sure what to change or how to verify it was successful.
>> In Lion's, I have opened Preferences -> Settings ->
>> Shell, checked the "Run command" box, and filled in
>> "/opt/local/bin/bash -l". The "Run inside shell" checkbox is not
>> checked. The bash port is installed. If I open a new terminal window
>> and type "echo $SHELL" it still prints "/bin/bash". Is that a correct
>> way to verify that these steps were not successful? What else should I
>> be doing?

> Try echo $BASH_VERSION. It should print something along the line of
> 4.2.something. If it doesn't you're not using MacPorts bash.

I upgraded my system this morning and I now have:
 bash @4.2.29_0+universal (active)
 bash-completion @2.0_1 (active)
I ran the following:

gbs:~ $ echo $BASH_VERSION
gbs:~ $ /bin/bash --version
GNU bash, version 3.2.48(1)-release (x86_64-apple-darwin10.0)
gbs:~ $ which bash
gbs:~ $ bash --version
GNU bash, version 4.2.29(2)-release (i386-apple-darwin10.8.0)

The results disagree with what Clemens said. Typing 'port SPACE TAB' gives me a listing of the current directory whereas it should give a list of all possible port commands if bash-completion is working.

How can I get $BASH_VERSION to give '4.2.29(2)-release'?


More information about the macports-users mailing list