Macports won't update under ML

Busser, Jim james.busser at
Wed Jul 25 23:09:59 PDT 2012

On 2012-07-25, at 9:04 PM, cruddell001 wrote:

> I updated to Mountain Lion today and ran sudo port selfupdate ...   Here is
> the output using the "-d" setting:
> pc:~ cruddell001$ sudo port selfupdate
> Password:
> ...
> checking Xcode location... /Developer
> checking Xcode version... 4.2.1

I updated to Mountain Lion without having ever had Xcode (or MacPorts) on my target machine.

I installed Xcode via the App Store, and note that it is version 4.4.

Also, anyone downloading Xcode from the App Store should also note that the App Store provides no option to select to also download and install the Command Line Tools, which is why -- when I tried a fresh install from MacPorts source -- I ran into

	no acceptable C compiler found in $PATH

Completion of the Xcode install that is required by MacPorts (via App Store download), requires another step. An Admin user needs to launch Xcode and go into File > Preferences and, under the Downloads pane, select to install the Command Line Tools. When you click Install, you are prompted to enter an Apple Developer ID and password, however the free (no charge) account which I had established some time ago was accepted and after a few minutes the status of the Command Line Tools was updated to "Installed".

I was then successful, under MacPorts -2.1.2 and after exiting Terminal and re-opening it, to run

	sudo make install

-- Jim

More information about the macports-users mailing list