graphviz problem: Warning: Could not load "/opt/local/lib/graphviz/libgvplugin_pango.6.dylib" - file not found

Ryan Schmidt ryandesign at
Fri Jun 1 10:17:53 PDT 2012

On Jun 1, 2012, at 11:46, Peng Yu wrote:

> On Fri, Jun 1, 2012 at 9:55 AM, Jeremy Lavergne
> <jeremy at> wrote:
>>> /opt/local/lib/graphviz/libgvplugin_pango.6.dylib
>> What version of libffi do you have installed? It was updated recently which broke graphviz, which was then marked for a rebuild just 30 minutes ago (
>> Try selfupdate and upgrade outdated ports, then see if graphviz works again.
> After I run 'sudo port upgrade outdated', I got the following.
> --->  Computing dependencies for orbit2
> --->  Deactivating orbit2 @2.14.19_0+universal
> --->  Cleaning orbit2
> --->  Activating orbit2 @2.14.19_1+universal
> --->  Cleaning orbit2
> Error: Requested variants "" do not match original selection "+universal".
> Please use the same variants again, perform 'port clean gconf' or
> specify the force option (-f).
> Error: Unable to upgrade port: 1
> To report a bug, follow the instructions in the guide:
> Should I run 'sudo port -f clean gconf'? I'm not sure if there is some
> unwanted consequence.

Yes, you should clean gconf, like the error message said to do (or use the same variants as you did last time). There is no need to force the clean.

More information about the macports-users mailing list