Rebuilding broken ports over...and over...and over

Craig Treleaven ctreleaven at
Fri Jun 15 10:01:53 PDT 2012


I seem to be unable to upgrade or install Qt4-mac on an older Core2 
Duo mini.  At first, I tried to just use port upgrade (after a 
selfupdate).  It fell over but I didn't save any logs.  This machine 
has had MacPorts on it for a long time--4 years plus or minus--but 
only for a couple of small things.  So I did "sudo port uninstall 
installed" which completed without complaint.

The attached log picks up with "sudo port install qt4-mac +mysql". 
That failed thusly:
>Error: Requested variants "" do not match original selection "+universal".
>Please use the same variants again, perform 'port clean perl5.12' or 
>specify the force option (-f).
>Error: Failed to install perl5.12

I then cleaned perl5.12 and tried "sudo port install perl5.12 
+universal".  It trundled away installing several universal versions 
of dependencies but while 'finishing' it found 4 broken ports and 
reinstalled them.  Then it found 2 broken ports (different this time) 
and reinstalled them.  After that it found 4 broken ports--the same 
it found the first time and reinstalled them.  Next it found 7 broken 
ports, including some repeats and some new, and ...  Eventually I hit 

Rather than mess around more, what is the best way to start 
fresh--short of wiping the disk and reinstalling OS X, XCode, etc?


More information about the macports-users mailing list