povray won't deploy

Murray Eisenberg murrayeisenberg at gmail.com
Fri Sep 14 13:32:38 PDT 2012

I just tried 'sudo port sync' and then 'sudo port upgrade povray'. All the requisite ports upon which this depends did build OK. And now the build of povray itself completed, apparently without error (although with warnings along the way).

However, there was an error at "Staging povray into destroot". The relevant portion of the log appears below.

Moreover, when I tried to run povray on a simple scene file, I got error:

 dyld: Library not loaded: /opt/local/lib/libpng14.14.dylib
 Referenced from: /opt/local/bin/povray
 Reason: image not found

Is this because the old version of povray is still around, the newer one did not in fact get placed in the destination directory, and the older one uses a different version of libpng that's been installed during an upgrade? I note that 'sudo port installed' shows:

 libpng @1.4.11_0
 libpng @1.4.12_0
 libpng @1.4.12_0+universal
 libpng @1.5.12_0+universal (active)

From log for 'sudo port upgrade povray':

:info:destroot Creating data directories...
:info:destroot Copying data files...
:info:destroot Creating documentation directories...
:info:destroot Copying documentation files...
:info:destroot Creating user directories...
:info:destroot usage: chown [-fhv] [-R [-H | -L | -P]] owner[:group] file ...
:info:destroot        chown [-fhv] [-R [-H | -L | -P]] :group file ...
:info:destroot usage: chown [-fhv] [-R [-H | -L | -P]] owner[:group] file ...
:info:destroot        chown [-fhv] [-R [-H | -L | -P]] :group file ...
:info:destroot make[2]: *** [install-data-local] Error 1
:info:destroot make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_povray/povray/work/povray-3.7.0.RC6'
:info:destroot make[1]: *** [install-am] Error 2
:info:destroot make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_povray/povray/work/povray-3.7.0.RC6'
:info:destroot make: *** [install-recursive] Error 1
:info:destroot make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_povray/povray/work/povray-3.7.0.RC6'
:info:destroot Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_povray/povray/work/povray-3.7.0.RC6" && /usr/bin/make -w install DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_povray/povray/work/destroot 
:info:destroot Exit code: 2
:error:destroot org.macports.destroot for port povray returned: command execution failed
:debug:destroot Error code: CHILDSTATUS 25395 2
:debug:destroot Backtrace: command execution failed
   while executing
"system -nice 0 $fullcmdstring"
   ("eval" body line 1)
   invoked from within
"eval system $notty $nice \$fullcmdstring"
   invoked from within
"command_exec destroot"
   (procedure "portdestroot::destroot_main" line 2)
   invoked from within
"$procedure $targetname"
:info:destroot Warning: targets not executed for povray: org.macports.install org.macports.destroot
Murray Eisenberg                     murrayeisenberg at gmail.com
80 Fearing Street                      phone 413 549-1020 (H)
Amherst, MA 01002-1912

More information about the macports-users mailing list