povray won't deploy

Murray Eisenberg murrayeisenberg at gmail.com
Sat Sep 15 13:03:39 PDT 2012

On Sep 15, 2012, at 19:23:59 -0500, Ryan Schmidt <ryandesign at macports.org> wrote:

> On Sep 14, 2012, at 15:32, Murray Eisenberg wrote:
>> I just tried 'sudo port sync' and then 'sudo port upgrade povray'. All the requisite ports upon which this depends did build OK. And now the build of povray itself completed, apparently without error (although with warnings along the way).
>> However, there was an error at "Staging povray into destroot". The relevant portion of the log appears below.
> Please file a bug report in the issue tracker and attach the entire main.log file. Please Cc me on the bug report and I'll have a look.
>> Moreover, when I tried to run povray on a simple scene file, I got error:
>> dyld: Library not loaded: /opt/local/lib/libpng14.14.dylib
>> Referenced from: /opt/local/bin/povray
>> Reason: image not found
>> Is this because the old version of povray is still around, the newer one did not in fact get placed in the destination directory,
> Yes.
>> and the older one uses a different version of libpng that's been installed during an upgrade? I note that 'sudo port installed' shows:
>> libpng @1.4.11_0
>> libpng @1.4.12_0
>> libpng @1.4.12_0+universal
>> libpng @1.5.12_0+universal (active)
> libpng was updated to 1.5.x recently, and some ports, including the old version of povray, were not compatible with this new version of libpng and therefore needed to be updated. So we need to figure out why the updated version of povray is not installing on your system.

I've now been able to get the povray port version 3.7.0RC6 to install and to run.

  sudo port uninstall povray
  sudo port clean povray            (is that step needed?)
  sudo port sync
  sudo port install povray

Murray Eisenberg                     murrayeisenberg at gmail.com
80 Fearing Street                      phone 413 549-1020 (H)
Amherst, MA 01002-1912

More information about the macports-users mailing list