gdk-pixbuf2 failed

Ryan Schmidt ryandesign at
Fri Sep 21 17:47:20 PDT 2012

On Sep 21, 2012, at 19:08, Frank J. R. Hanstick <trog24 at> wrote:

> While trying to upgrade, the following error occurred during configuration:
> :info:configure checking for GLIB - version >= 2.31.0...
> :info:configure *** 'pkg-config --modversion glib-2.0' returned 2.32.4, but GLIB (2.28.8)
> :info:configure *** was found! If pkg-config was correct, then it is best
> :info:configure *** to remove the old version of GLib. You may also be able to fix the error
> :info:configure *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
> :info:configure *** /etc/ Make sure you have run ldconfig if that is
> :info:configure *** required on your system.
> :info:configure *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
> :info:configure *** to point to the correct configuration files
> :info:configure no
> :info:configure configure: error:
> :info:configure *** GLIB 2.31.0 or better is required. The latest version of
> :info:configure *** GLIB is always available from

And what version of the glib2 port is actually installed?

port installed glib2

The version currently available in MacPorts is 2.32.4 which should satisfy the above requirement.

More information about the macports-users mailing list