Does povray port work on Mountain Lion?

Ryan Schmidt ryandesign at
Sun Apr 14 23:26:26 PDT 2013

On Apr 14, 2013, at 19:34, Murray Eisenberg wrote:

> The only macports version of povray I find is 3.7.

And that's because that's the only version MacPorts offers right now. :) More specifically, 3.7.0.RC7. We used to try to offer the latest stable version 3.6.1 but it did not build anymore and it was 8 years old so I decided to update to the newest release candidate 3.7.0.RC6 instead; see:

> Even with the example you give, executing the command "povray +O/tmp/out shapes.pov" gave:
>   dyld: lazy symbol binding failed: Symbol not found: __ZN5boost6thread12start_threadEv
>      Referenced from: /opt/local/bin/povray
>      Expected in: /opt/local/lib/libboost_thread-mt.dylib
>   dyld: Symbol not found: __ZN5boost6thread12start_threadEv
>     Referenced from: /opt/local/bin/povray
>     Expected in: /opt/local/lib/libboost_thread-mt.dylib
>   Trace/BPT trap: 5
> I uninstalled and cleaned all installed versions of povray and reinstalled. Now it works. Unclear how things had gotten messed up.

When povray was updated to 3.7.0.RC7, boost 1.52 was current and povray worked. Later, boost was updated to 1.53, which caused any already-build povray to fail with the above error message. If you got povray from our packages server, you would also have been affected by this, even if you installed povray recently.

Fixed by increasing povray's revision to make it rebuild with boost 1.53; see:

More information about the macports-users mailing list