port selfupdate failing

Gustavo Seabra gustavo.seabra at gmail.com
Fri Dec 13 05:12:42 PST 2013

Hi everyone,

Just an update on this issue, in case someone ever faces the same problema again:

The whole problem was because 'selfupdate' would work only over rsync, and that was blocked in my network. So, what I did and worked fine for me was:

1) Following Ryan Schmidt's suggestion, I installed the MacPorts base from the website 

2) Following Jeremy Lavergne's tip, I configured MacPorts to use svn, but just skipped the proxy configuration part (step 3 in http://trac.macports.org/wiki/howto/SyncingWithSVN).

3) back to Ryan's message: Now, I could just do a 'sudo port sync' to update the ports, and all works fine since.

Big thanks to Jeremy and Ryan for all the help.

Gustavo Seabra.

On Dec 4, 2013, at 8:13 PM, Ryan Schmidt <ryandesign at macports.org> wrote:

> On Dec 4, 2013, at 15:34, Gustavo Seabra wrote:
>> Steps 1 and 2 worked just fine. skipping step 3 I get the message below (basically, nothing changes.)
>> I attach my sources.conf file here, in case it helps.
>> Thanks!
>> Gustavo.
>> $ sudo port -d selfupdate
>> DEBUG: Copying /Users/seabra/Library/Preferences/com.apple.dt.Xcode.plist to /opt/local/var/macports/home/Library/Preferences
>> DEBUG: MacPorts sources location: /opt/local/var/macports/sources/rsync.macports.org/release/tarballs
>> --->  Updating MacPorts base sources using rsync
>> rsync: failed to connect to rsync.macports.org: Operation timed out (60)
>> rsync error: error in socket IO (code 10) at /SourceCache/rsync/rsync-42/rsync/clientserver.c(105) [receiver=2.6.9]
>> Command failed: /usr/bin/rsync -rtzv --delete-after rsync://rsync.macports.org/release/tarballs/base.tar/opt/local/var/macports/sources/rsync.macports.org/release/tarballs
>> Exit code: 10
>> DEBUG: Error synchronizing MacPorts sources: command execution failed
>>     while executing
>> "macports::selfupdate [array get global_options] base_updated"
>> Error: Error synchronizing MacPorts sources: command execution failed
>> To report a bug, follow the instructions in the guide:
>>     http://guide.macports.org/#project.tickets
>> Error: /opt/local/bin/port: port selfupdate failed: Error synchronizing MacPorts sources: command execution failed
>> $
> The error messages tell us rsync communications are not working on your network. Has this always been the case, or did selfupdate used to work? Did something recently change about your network? If you have one, have you spoken with your network administrator?
> It's normal that editing sources.conf would not fix this because that only affects "port sync", not "port selfupdate". If you cannot make rsync work on your network, then you cannot use selfupdate and must use sync, and when a new version on MacPorts base is released, you must install it using the installer package we post on our web site. 

More information about the macports-users mailing list