Trouble installing a port variant of php55

René Fournier m5 at
Fri Dec 27 13:23:46 PST 2013

Oh wow, I had tried so many variations of the command, I had [obviously] stopped paying attention to the error message. Sorry for the dumb question… Yes, cleaning and reinstalling worked. Thanks!

On Dec 27, 2013, at 2:20 PM, Brandon Allbery <allbery.b at> wrote:

> On Fri, Dec 27, 2013 at 4:12 PM, René Fournier <m5 at> wrote:
>       sudo port install php55-postgresql +postgresql92
> I get:
>    Error: Requested variants "+postgresql92" do not match original selection “".
>    Please use the same variants again, perform 'port clean php55-postgresql' or specify the force option (-f).
>    To report a bug, follow the instructions in the guide:
>    Error: Processing of port php55-postgresql failed
> Did you read the error message? 
> It means that there is already a build tree (from an error or aborted build) for a different variant. If you want to build +postgresql92, you must first "sudo port clean php55-postgresql" to remove the existing build tree, as the error message told you.
> -- 
> brandon s allbery kf8nh                               sine nomine associates
> allbery.b at                                  ballbery at
> unix, openafs, kerberos, infrastructure, xmonad

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list