gcc48/gcc49: isalnum/isgraph: Undefined symbols for architecture x86_64

Brian D. McGrew brian at visionpro.com
Wed Nov 6 15:44:40 PST 2013

>>I¹m getting an undefined symbol for isalnum and isgraph using g++-mp-4.8.
>> I found this article here:
>>1-in-mavericks which mentions the issue in Mavericks and the Xcode
>>command line tools.  However, I¹m using MP and the g++ from mp when
>>trying to build.  And yes, I rebuilt ports, from scratch, when I
>>upgraded (clean install) to Mavericks.
>> It could just be me missing something, but I¹ve tried everything I can
>>think of and every combination of google searches to figure this one
>>out.  The code is very simple (I think).  Oh, and yes, I did a
>>+universal when I installed gcc49 and gcc48.  And if it matters, I
>>installed gcc49 (with libgcc) before gcc48.  When I tried gcc48 then
>>gcc49 I got an error about libgcc, but doing it the other way works.
>> What am I missing???
>> Thanks,
>> -b
>> #include <ctype.h>
>Shouldn't that be '#include <cctype>' since you're compiling as C++?

Yeah, probably so.  It¹s compiled like this for over a year in MacOS 7 and
8Š  It¹s just now that I¹ve gone to 9 it¹s a problem.  And, changing it to
#include <cctype> didn¹t change anything.


More information about the macports-users mailing list