having trouble syncing via svn behind corporate firewall

Richard Cobbe cobbe at ccs.neu.edu
Thu Nov 14 16:30:54 PST 2013

I'm having some difficulty syncing the latest macports package list via svn
on a MacMini (10.8.5, XCode 5.latest) that's running behind a corporate
firewall that blocks rsync.

(I'd like to apologize in advance for the fact that there's going to be a
lot of latency in my replies to this thread -- the corporate firewall is
only at work, of course, and I have very limited access to this mail
account there.)

I followed the directions at
<http://trac.macports.org/wiki/howto/SyncingWithSVN>, and after modifying
both ~/.subversion/servers and ~root/.subversion/servers to use the
corporate http proxy, I was able to perform the initial checkout with no

I've also modified /opt/local/etc/macports/sources as specified on the web
page above.  Unfortunately, I forgot to send a copy of that file home
today, but I'm pretty sure the relevant line reads
  file:///opt/local/var/macports/sources/svn.macports.org/trunk/dports/ [default]

That's certainly what I *intend* it to read, anyway, and I'll double-check
that tomorrow.  I also commented out the rsync line.

So, as I said, the initial checkout went fine (run as root).  But when I
then try to run "port -d sync", it fails.  The console output (attached)
seems to suggest that there's a problem with the "svn up" command, but I'm
able to run that exact same command by hand and it completes with no error
messages, and $? is 0.

Thinking that HTTPS vs. HTTP might be the problem, I even ran "svn switch
--relocate" in the checked out copy to switch the existing one to http://
instead of https://, but this didn't make any difference.  Running "svn up"
by hand still works, running "port -d sync" still doesn't.

(BTW, I wondered about HTTPS because the first time I tried to check out, I
got a message from svn about how the certificate wasn't properly signed.  I
said "permanently accept", and I haven't been bothered with it since.)

I can fall back on using the daily tarball, but I'd really rather not, as
it's quite slow.  Does anyone have any suggestions for how to get svn
syncing working?  Or are there other places I should be looking to find
more information about the cause of this failure?

Note that most of this stuff was run within a shell created by "sudo -i",
so I *know* I'm getting root's SVN configuration, not mine.  (Annoying that
I have to do that, but that's the price of living behind a firewall.  :-/ )
Oh, and I don't think I have any PROXY environment variables set; I'm
relying on the svn config files for that.  But I believe I tried it with
those as well, and it didn't seem to make any difference.


-------------- next part --------------
ironcrust:~ root# port -d sync
--->  Updating the ports tree
Synchronizing local ports tree from file:///opt/local/var/macports/sources/svn.macports.org/trunk/dports/
DEBUG: /usr/bin/svn update --non-interactive /opt/local/var/macports/sources/svn.macports.org/trunk/dports
DEBUG: changing euid/egid - current euid: 0 - current egid: 0
Updating '/opt/local/var/macports/sources/svn.macports.org/trunk/dports':
svn: E175002: Unable to connect to a repository at URL 'https://svn.macports.org/repository/macports/trunk/dports'
svn: E175002: OPTIONS of 'https://svn.macports.org/repository/macports/trunk/dports': could not connect to server (https://svn.macports.org)
Command failed: /usr/bin/svn update --non-interactive /opt/local/var/macports/sources/svn.macports.org/trunk/dports
Exit code: 1
DEBUG: command execution failed
    while executing
"system $svn_commandline"
Error: Synchronization of the local ports tree failed doing an svn update
DEBUG: Synchronization of 1 source(s) failed
    while executing
"mportsync [array get global_options]"
port sync failed: Synchronization of 1 source(s) failed
ironcrust:~ root# /usr/bin/svn update --non-interactive /opt/local/var/macports/sources/svn.macports.org/trunk/dports
Updating '/opt/local/var/macports/sources/svn.macports.org/trunk/dports':
At revision 113381.
ironcrust:~ root# echo $?
ironcrust:~ root# /usr/bin/svn update /opt/local/var/macports/sources/svn.macports.org/trunk/dports
Updating '/opt/local/var/macports/sources/svn.macports.org/trunk/dports':
At revision 113381.

More information about the macports-users mailing list