HELP!! Trouble running Macports

Alia Jemmali alia.jemmali at
Fri Nov 15 18:11:15 PST 2013

Dear Macports suporter,
I have Macbook Pro version 10.8.5 Mountain lion. so i have installed xcode
( Version 5.0.2) and the command line tools for Mountain lion, then i
downloaded the dmg Macports, for Mountain lion, using The Mac OS X package
installer as it was suggested. After all the installation successfully done
i have opened the command line to see if it works by following the methods
of using Macports in their guide website and it doesn't work. For instance,
i typed sudo port selfupdate and it show a message as the following (PS:
And i can't enter my password i tried to enter it but it doesn't even
wanted to enter it (don't want to be typed) :

MacBook-Pro-de-MACBOOKPRO:~ macbookpro$ sudo port selfupdate

WARNING: Improper use of the sudo command could lead to data loss
or the deletion of important system files. Please double-check your
typing when using sudo. Type "man sudo" for more information.

To proceed, enter your password, or type Ctrl-C to abort.


Then i tried to type port list it show me this

MacBook-Pro-de-MACBOOKPRO:~ macbookpro$ port list
Warning: Can't open index file for source: rsync://
Error: listing all ports failed: No index(es) found! Have you synced your
port definitions? Try running 'port selfupdate'.

So what should i do please help me to solve those problems?

Thank you
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list