libgcc 4.8.1 errors on a fresh install macports for Mavericks (OS X 10.9)

William Capehart wjcapehart at
Thu Oct 31 20:17:49 PDT 2013

I began to duplicate Zhong Ren¹s procedure (below) after "uninstall ­f
all²ing  all and ³clean all²ing

I started with trying to install gcc45.

During the gcc45 build it tried to install libgcc and we were back at the
same error again.  :-(


From:  Zhong Ren <renzresearch at>
Date:  Thursday, October 31, 2013 at 11:12 MDT
To:  William Capehart <wjcapehart at>
Cc:  MacPorts Users <macports-users at>
Subject:  Re: libgcc 4.8.1 errors on a fresh install macports for Mavericks
(OS X 10.9)

What I did exactly is:

install gcc45
install python27
install py27-scipy

The last step requires gcc48, so it went on installing gcc48 first.  This
sequence may have nothing to do with the error you have.  Just for the

Sometimes when an error occurs, I have to uninstall a specific port with -f,
clean that port, and install that port again.


On Oct 31, 2013, at 11:42 AM, William Capehart <wjcapehart at> wrote:

> I just restored my /opt/local from my early October Time Machine image,
> reinstalled Xcode 5.0.1 and command lines tools from the Apple Developer site,
> did the license step and self updated yet another brand-new fresh install of
> Macports¹s Mavericks dmg  and went through all of the migration steps advised
> here, and the exact same libgcc error I got was below.
> Also tried Zhong Ren¹s approach and installed py27-scipy.  Once again at
> libgcc install, it is still dropping me out of the build with the "typedef
> enum pointer_t pointer_t² conflict.
> I do not know if Zhong Ren¹s install built the dependencies  libgcc or gcc48
> from scratch before building py27-scipy.
> Unless there are other ideas, I am on the ropes with this at this point.
> Bill Capehart
> From:  Zhong Ren <renzresearch at>
> Date:  Tuesday, October 29, 2013 at 15:15 MDT
> To:  William Capehart <wjcapehart at>
> Cc:  MacPorts Users <macports-users at>
> Subject:  Re: libgcc 4.8.1 errors on a fresh install macports for Mavericks
> (OS X 10.9)
> I just installed py27-scipy on a fresh Mavericks, which requires gcc48.  It
> went through OK.
> Zhong Ren
> On Oct 29, 2013, at 3:46 PM, William Capehart <wjcapehart at> wrote:
>> I put in a bug report on this but nothing back yet so I¹ll try here.
>> Has anyone tried to put the gcc (4.7 or 4.8) compilers on *fresh* Macports
>> for Mavericks install?
>> For me having ..
>>    - reinstalled both macports and Xcode (or just the app in /Applications),
>> (on that note is there a way to totally sterilize Xcode from a Mac so we can
>> start at ground zero?  Oddly Xcode did NOT ask for an update (and the update
>> happened well and advance of my going to Mavericks)  IIRC, my previous OS
>> upgrades had me install the new Xcode AFTER upgrading.
>>    - gotten the command line tools for mavericks¹s Xcode from the apple
>> developer site
>>         ‹  xcode-select ‹install fails so I got it here as per guidance from
>> the apple developer forums
>>    - done the license agreement step
>> I still get a terminal error from the installs for gcc47 and gcc48 at the
>> libgcc step:
>> /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.
>> org_release_tarballs_ports_lang_gcc48/libgcc/work/gcc-4.8.1/gcc/fortran/modul
>> e.c:110:1: error: conflicting declaration 'typedef enum pointer_t pointer_t'
>>  pointer_t;
>>  ^
>> In file included from /usr/include/mach/memory_object_types.h:77:0,
>>                  from /usr/include/mach/mach_types.h:85,
>>                  from
>> /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.
>> org_release_tarballs_ports_lang_gcc48/libgcc/work/build/prev-gcc/include-fixe
>> d/malloc.h:37,
>>                  from
>> /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.
>> org_release_tarballs_ports_lang_gcc48/libgcc/work/gcc-4.8.1/gcc/system.h:460,
>>                  from
>> /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.
>> org_release_tarballs_ports_lang_gcc48/libgcc/work/gcc-4.8.1/gcc/fortran/modul
>> e.c:68:
>> /usr/include/mach/vm_types.h:40:26: error: 'pointer_t' has a previous
>> declaration as 'typedef vm_offset_t pointer_t'
>>  typedef vm_offset_t      pointer_t;
>>                           ^
>> This error doesn¹t seem to be the Tcl problem reported by others nor does it
>> resemble the one reported here for gcc44 earlier this weekŠ
>> Has anyone run into this besides me with the new macports on Mavericks?  (or
>> for that matter EVER).
>> Thanks
>> Bill Capehart 
>> _______________________________________________
>> macports-users mailing list
>> macports-users at

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list