qucs fails from iverilog arch issues

Ryan Schmidt ryandesign at macports.org
Mon Sep 30 22:29:09 PDT 2013

On Sep 30, 2013, at 21:25, Jean-François Caron wrote:

> So three years ago this bug was opened: https://trac.macports.org/ticket/27520
> The latest modifications are from 8 months ago.  The problem still persists:
> fcaron at dhcp-128-189-75-8:~$ sudo port install qucs
> Password:
> --->  Computing dependencies for qucs
> Error: Cannot install qucs for the arch(s) 'i386' because
> Error: its dependency iverilog does not build for the required arch(s) by default
> Error: and does not have a universal variant.
> Error: Unable to execute port: architecture mismatch
> I tried a variant on the reported workaround with "build_arch=x86_64", but qucs still tries to build for i386 (meaning that the port has a bug since it ignores the build_arch flag).  
> I tried the same workaround as in the bug report, building iverilog with "build_arch=i386" and THEN qucs.  A problem occurs when configuring qt3-mac: 
> --->  Configuring qt3-mac
> Error: org.macports.configure for port qt3-mac returned: configure failure: command execution failed
> Error: Failed to install qt3-mac
> Here is the log file from that, but the important part is "This version of Mac OS X is unsupported."  
> <main.log>
> I am on a MacBook Pro (Late 2011), running Mac OS X 10.7.5, MacPorts 2.2.0, XCode 4.5.1 (4G1004).
> Is this port abandoned?  The latest binary on their website seem to be for OSX 10.5 only (they crash immediately when running, with no useful debug messages):
> <qucslog.log>
> If the program just isn't intended to work on 10.7 (or other new OSXes), then the user should be told this earlier in the process.

Sorry, Qt 3 is ancient, and I would not expect it to work today. The build failure is already reported to us some time ago:


However the Qt developers are no longer releasing updates to Qt 3, and it's probably not worth our time to try to look into it ourselves. Qt is a very complex piece of software and it would probably take a lot of work to figure out what the problem is, and effort would be better spent on getting software to use Qt 4 instead.

In your case that software is Qucs. I checked the Qucs web site and they have a new version available. Their web site seems not to be entirely updated, and some parts of it still refer to Qt 3, but the build page says the current version requires Qt 4, and on the download page they have a pre-compiled binary for OS X built with Qt 4.8, so that's promising.

I've filed a ticket requesting the port be updated:


More information about the macports-users mailing list