Can't set tmpdir in mysql

Darwin O'Connor doconno at
Thu Jan 9 11:04:26 PST 2014

I got it working now.

I did mean /opt/local/etc/my.cnf but it turns out the file need to be in
/opt/local/etc/mysql5/my.cnf. When I had a my.cnf in there it caused mysql
startup to fail saying "Manager of pid-file quit without updating file." I
thought it was a problem with the pid file. I finally saw in the log it was
"File ‘./mysql-bin.index’ not found (Errcode: 13)" I solved it by removing
binary logging from the my.cnf as recommended

/var/tmp doesn't work unless I change the ownership from root:wheel to
root:admin, but that gets undone after reboot, so I created /opt/local/tmp.
It is using this directory correctly now, as specified in the my.cnf.

On Tue, Jan 7, 2014 at 9:48 AM, Ryan Schmidt <ryandesign at>wrote:

> On Jan 6, 2014, at 22:28, Darwin O'Connor wrote:
> > I haven't been able to change the tmpdir for mysql.
> I doubt this is a MacPorts-specific issue so you may have more luck
> writing to a MySQL-specific support venue.
> > I've set it to /opt/local/tmp in my.cnf
> You mean /opt/local/etc/my.cnf? Are the other values in this file taking
> effect? Changing them does actually change things? I ask because MySQL
> checks various locations for my.cnf files, and I don’t remember what the
> order is or what happens if they’re found in multiple locations; possibly
> one of them takes precedence.
> > but mysql still uses /var/tmp which never worked for some reason. I see
> no errors in the mysql log file.
> In what way does using /var/tmp as the temporary directory not work?
> > I believe I had it working before, but the my.cnf was wiped during an
> incident when the disk was full.
> >
> > This is ls -l for the tmp directory
> > drwxrwxrwx    2 root  admin     68  5 Jan 21:54 tmp
> This is /var/tmp or /opt/local/tmp?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list