Troubles installing ports with Macports 2.3.1

Joël Brogniart Joel.Brogniart at
Tue Jul 1 02:29:43 PDT 2014

Le 30 juin 2014 à 15:46, Joël Brogniart <Joel.Brogniart at> a écrit :

> Le 30 juin 2014 à 14:39, Ryan Schmidt <ryandesign at> a écrit :
>> On Jun 30, 2014, at 4:45, Joël Brogniart wrote:
>>> With OS X 10.9.3, Xcode 5.1.1, Macports 2.3.1
>>> I have troubles installing ports with Macports 2.3.1.
>>> First I removed Macports 2.2.1 following instructions from <>. Then I downloaded Macports 2.3.1 installer for Mavericks and I installed Macports 2.3.1.
>> Any particular reason why you uninstalled the old version first? Usually you just install the new version on top, or even more usually run "sudo port selfupdate" which does it for you.
> Bad habits perhaps. I was working since may on a project for which I had to keep the macports tools stable (no updates during the duration of the project). After the end of the project, I'd like to go back to a clean state to ease documentation of the various steps that lead to the realization of a project and limit interactions. And also to reduce unnecessary tools that could stay on a drive years after their last usage.
>>> :error:main Failed to install m4
>>> :debug:main /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_m4/m4: too many open files
>> Too many open files... Are you doing anything else on your computer that would open lots of files? Try closing other applications or restarting the computer. 
> I alway have a lot of open applications on my machine (mail, safari, contacts, calendar, note, messages, itunes, terminal, textmate, libreoffice, dictionary, translation dictionary) plus Apache (from and standard Apple processes, but haven't encounter the max open file limit for years until this morning.
> I closed all my apps, restarted and tried again to install a port and get the same result. As previously if I clean the port which installation just failed and install it again, then the install succeed. With only launched I nevertheless have more than 5k open files, as reported by lsof and before using macports.
> It seems to me that the problem is in part with Mavericks and in part with Macports. I'll do some more tests to narrow the problem. Perhaps last Mavericks update lowered the max open file per process limit.

Yesterday, I tested Macport installation and the same set of commands on two others Mac (OS X 10.9.3, Macports 2.3.1) and wasn't able to reproduce the problem with these machines. At one time, after having done a lot of things I tried again on my machine and I worked! I can't say what make the installation succeed.

So this morning, hopeful, I updated my machine to 10.9.4, uninstalled Macports and tried again. Sad! Same failure with a too many open files errors. Using crtl-z to pause the macport install command in bash, I was able to see that there was a lot of
	tclsh8.5 12379 root 12u IPv4 0x28ea3571bc78bb01 0t0 TCP localhost:57962->localhost:8228 (CLOSE_WAIT)
and that the error happens when the number of tclsh open files is arround 260.

For the now, I bypassed the problem by installing first one big port the final product depends on. Then I  installed the final product. I still don't know where the problem comes from. Perhaps optimisation or cache feature with Apple's managment of SSD drives.

> To be honest I am having similar problems on one of my Mavericks machines still running 2.2.1 but my problems began after an improper shutdown and I was assuming some kind of OS corruption and was planning on reinstalling the OS when I have some time, so please let me know what the solution turns out to be for you.
> Joël

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 841 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <>

More information about the macports-users mailing list