a) Searching the Archives & b) Uninstalling

David Winsemius dwinsemius at comcast.net
Thu Jul 31 19:08:28 PDT 2014

On Jul 31, 2014, at 6:07 PM, Bradley Giesbrecht wrote:

> On Jul 31, 2014, at 5:46 PM, David Winsemius <dwinsemius at comcast.net> wrote:
>> Apologies if I am retracing old ground, but I could not find a FAQ or a link to a search facility to the Archives on the user-support page: https://lists.macosforge.org/mailman/listinfo/macports-users .  
>> a) I'm a regular reader and contributor to r-help and typically use Markmail for searching the R-help archives, but do not see that this macports is archived there.  Where or how do people generally search?
> Is MacPorts List Archives [1] what you are after?
>> b) I'm trying to adhere to the conventions that the official Mac port of R is using and they do not like packages installed with Macports, homebrew or Fink because R modules (if that is the right word) are statically linked and they do not feel that the choice of where packages get put by these installation services end up in the canonical directory. So I am trying to update my curl installation and I think it was installed with macports, probably some time ago before I updated to Lion v 10.7.5. I don;'t see much point in updating to ML and there are current problems with Mavericks installation of R so I'm not ready to take that leap forward, either.
>> At the moment I'm getting this response to my efforts at even  updating Macpoorts:
>> david-winsemiuss-mac-pro:~ davidwinsemius$ sudo port selfupdate
>> --->  Updating MacPorts base sources using rsync
>> MacPorts base version 2.1.3 installed,
>> MacPorts base version 2.3.1 downloaded.
>> --->  Updating the ports tree
>> --->  MacPorts base is outdated, installing new version 2.3.1
>> Warning: Disabling readline support due to readline in /usr/local
> You might move /usr/local [2] out of the way before you perform "sudo port selfupdate".
> mv /usr/local{,-moved}
> sudo port selfupdate
> mv /usr/local{-moved,}

I tried that and it failed with the same error message. I looked up reports of failure in gmane's version of the Archives and found a variant on that which I assumed was a verbose flag. It was very verbose and the final  few bits of output looked like this:

$ sudo port -vf selfupdate

Snipped many pages of output....

/usr/bin/cc -c -DUSE_TCL_STUBS -DTCL_NO_DEPRECATED -g -O2 -std=c99 -Wextra -Wall -pedantic     -DHAVE_CONFIG_H -I/opt/local/var/macports/sources/rsync.macports.org/release/tarballs/base/src -I/opt/local/var/macports/sources/rsync.macports.org/release/tarballs/base/src -I. -I/opt/local/var/macports/sources/rsync.macports.org/release/tarballs/base/vendor/vendor-destroot//opt/local/libexec/macports/include -fno-common sha1cmd.c -o sha1cmd.o
/usr/bin/cc -c -DUSE_TCL_STUBS -DTCL_NO_DEPRECATED -g -O2 -std=c99 -Wextra -Wall -pedantic     -DHAVE_CONFIG_H -I/opt/local/var/macports/sources/rsync.macports.org/release/tarballs/base/src -I/opt/local/var/macports/sources/rsync.macports.org/release/tarballs/base/src -I. -I/opt/local/var/macports/sources/rsync.macports.org/release/tarballs/base/vendor/vendor-destroot//opt/local/libexec/macports/include -fno-common curl.c -o curl.o
In file included from curl.c:46:
In file included from /usr/local/include/curl/curl.h:35:
/usr/local/include/curl/curlrules.h:143:6: error: '__curl_rule_01__' declared as an array with a negative size
    [CurlchkszEQ(long, CURL_SIZEOF_LONG)];
/usr/local/include/curl/curlrules.h:132:27: note: expanded from macro 'CurlchkszEQ'
#define CurlchkszEQ(t, s) sizeof(t) == s ? 1 : -1
1 error generated.
make[2]: *** [curl.o] Error 1
make[1]: *** [all] Error 1
make: *** [all] Error 1
Command failed: cd /opt/local/var/macports/sources/rsync.macports.org/release/tarballs/base && CC=/usr/bin/cc ./configure --prefix=/opt/local --with-tclpackage=/Library/Tcl --with-install-user=root --with-install-group=admin --with-directory-mode=0755 && make && make install SELFUPDATING=1
Exit code: 2
Error: /opt/local/bin/port: port selfupdate failed: Error installing new MacPorts base: command execution failed

It appears I have thoroughly broken my macports installation.

>> Installing new MacPorts release in /opt/local as root:admin; permissions 0755; Tcl-Package in /Library/Tcl
>> Error: /opt/local/bin/port: port selfupdate failed: Error installing new MacPorts base: command execution failed
>> -----------------
>> I've read that trying to uninstall macPorts can be dangerous and advised to pose my question here. What advice can anyone offer.
> Perhaps reading "Migrating a MacPorts install to a new major OS" [3] will help you be more comfortable uninstalling and reinstalling ports that are important to you.
> [1] https://trac.macports.org/wiki/MailingLists
> [2] https://trac.macports.org/wiki/InstallingMacPorts#source_privileged
> [3] https://trac.macports.org/wiki/Migration
> Regards,
> Bradley Giesbrecht (pixilla)

David Winsemius
Alameda, CA, USA

More information about the macports-users mailing list