Can't upgrade, install or uninstall port

Ryan Schmidt ryandesign at
Sun Nov 16 17:11:21 PST 2014

On Nov 16, 2014, at 5:56 PM, Emmanuel Marin wrote:

> I have recently upgrade my MacBook Pro with Yosemite. Today I  have installed the new version of Macport with success. 
> After that I have tried to upgrade ports with the command ’sudo port upgrade outdated’ and everything was good at the beginning but after 2 or 3 hours of work my Mac  close the session.

What do you mean exactly, "close the session"?

> Now when I want to use Macport for example to upgrade qtiplot after using ‘sudo port upgrade qtiplot’ everything is freeze with this message ‘Waiting for lock on /opt/local/var/macports/registry/.registry.lock’.
> I have tried to re-install MacPort but nothing change.
> What should I do with my Macport?

Sounds like MacPorts is still working on doing what you asked it to do before (upgrade outdated ports). You could confirm in Activity Monitor whether a "port" process is still running. Assuming there is, you could wait for it to complete.

More information about the macports-users mailing list