postfix install failed

Terry Barnum terry at
Tue Oct 21 10:07:13 PDT 2014

On Oct 21, 2014, at 6:47 AM, Marius Schamschula <lists at> wrote:

> Ryan,
> On Oct 20, 2014, at 5:17 PM, Ryan Schmidt <ryandesign at> wrote:
>>> On Oct 20, 2014, at 4:16 PM, Terry Barnum <terry at> wrote:
>>> Thanks for the -v suggestion. I did a 'sudo port -v selfupdate' which updated to 2.3.2, then updated to XCode 6.1 (for 10.9--haven't updated to 10.10 yet) and downloaded the CLI tools. I did a 'sudo port clean --dist postfix' and then 'sudo port -v install postfix +dovecot_sasl+pcre+tls'. Following <> I also changed my DNS servers from Google back to Cox DNS but I still get:
>>> --->  Checksumming postfix-2.11.2.tar.gz
>>> Error: Checksum (rmd160) mismatch for postfix-2.11.2.tar.gz
>>> Portfile checksum: postfix-2.11.2.tar.gz rmd160 a9ca0d269144e6b45848c4a6c414acdcc3bb896b
>>> Distfile checksum: postfix-2.11.2.tar.gz rmd160 c0aeb72ec03c4fb8674523522942e052fd7022d3
>>> Error: Checksum (sha256) mismatch for postfix-2.11.2.tar.gz
>>> Portfile checksum: postfix-2.11.2.tar.gz sha256 aa6eba4842457c88c48fb65faeb4fc6496cb3e9ceb9e0ddcb3c13b501821a258
>>> Distfile checksum: postfix-2.11.2.tar.gz sha256 f5e4f9dcdc63139c3f5a3540026d9cc78126ce32caed82e26293cd2cc8888ba3
>>> ***
>>> The non-matching file appears to be HTML. See this page for possible reasons
>>> for the checksum mismatch:
>>> <>
>>> ***
>>> The file has been moved to: /opt/local/var/macports/distfiles/postfix/postfix-2.11.2.tar.gz.html
>> And what is the contents of that file
> Yesterday morning I ran livecheck on postfix and found that postfix 2.11.3 is out.
> I updated the Portfile, only to find html in the downloaded file. I checked the mirror site and found that it redirects to
> I deleted this mirror from the master_sites list and all is well.
> Marius
> --
> Marius Schamschula

Thank you for the explanation Marius. This morning I ran 'sudo port -v selfupdate' and 'sudo port clean --dist postfix' then 'sudo port -v install postfix +dovecot_sasl+pcre+tls' but still get postfix-2.11.2 that fails to build due to the Dejan SEO html file.


Terry Barnum
digital OutPost

More information about the macports-users mailing list